Какую Joomla установить?
(7 Голосов)

У многих пользователей и начинающих программистов, зачастую, возникает вопрос, какую версию Joomla выбрать для дальнейшего использования, с какой версии лучше всего начать, какая версия наиболее выгодная для употребления и наиболее удобная  для клиентов. Ответ на этот вопрос должен дать себе каждый спрашивающий.  На данный момент имеется огромное число версий CMS Joomla, многие программисты, хорошо знающие своё дело, то и дело создают собственные релизы, наполненные различными модулями и дополнениями, которых нет в официальных, чистых версиях.

Если отталкиваться от того, что официальная версия нам предлагает, то, по-моему, лучше всего начинать с версии CMS Joomla 1.5, ввиду того, что она существенно отличается от своей прежней версии 1.0. Функционал значительно обширнее и намного яснее панель администратора.  Но это лишь отдельно взятый субъективный взгляд. Что касается точки зрения специалистов, то они утверждают, что разница между каждой версией движка весьма существенная.

Итак, начнем дискуссию с первой версии и ветки движка Joomla 1.0, т.е. с чего все началось. Данная версия движка считается так же и мамбой, однако, в отличии от оригинальной мамбы, данная ветка имеет некоторые доработки.  Что касается унаследованной версии т.е. Joomla 1.5, то можно смело сказать, что данная версия движка была написана абсолютно с нуля и, практически не похожа на 1.0. Новая версия, к сожалению, не достигла своего совершенства, и в ней часто встречаются различные багги и проблемы, с которыми безуспешно пытаются справиться ведущие специалисты компании. Версия 1.5 оказалась весьма требовательной к хостингам, поэтому возникает целый ряд проблем, с которыми часто сталкиваются новички. Кроме того, новая версия стала более объемной и громоздкой, её необходимо длительно закачивать на сервер, а для того, что бы сервер тянул данный продукт, он, как минимум, должен быть не слабым.  Сравнений можно привести огромное множество, но если сопоставить  реальные версии, то продукт 1.5  уступает продукту 1.0, не своей красотой и удобством, а своим функционалом.  Многие установочные пакеты и дополнительные модули, предназначенные для Joomla 1.0, гораздо эффективнее работают, нежели те же самые модули, установленные на Joomla 1.5  при включенном режиме Legacy. Legacy, или режим совмести старых модулей с версией 1.5 Joomla, работает не всегда так успешно, как этого хотелось бы, поэтому и данный нюанс, является еще одним минусом в сторону версии 1.5.

Уже вышла новая версия Joomla 1.6, на данный момент ничего конкретного сказать по данной версии нельзя, поскольку, во-первых, данная версия не русифицирована, во-вторых, она содержит значительное число ошибок и баггов, которые еще необходимо устранить. Поэтому подождем оглашения приговора, касательно данной версии, кто знает, может именно она станет, в последствии, приемником 1.0.

 

Главная Статьи Какую Joomla установить?